"Error Invoking Main Method" When Launching PAM Client
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"Error Invoking Main Method" When Launching PAM Client

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Article ID: 266399

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When some end users attempt to launch the PAM Client, the following error occurs.

Error invoking main method

Cause

This error will appear if global variables such as _JAVA_TOOLS_OPTIONS or JAVA_TOOLS_OPTIONS are pointing to a different version of Java than the one being used by the PAM client.

Resolution

Deleting the Windows environment variables allowed the PAM client to launch successfully.

Additional Information

To determine the current Java version the PAM client is using, run the command below.

> C:\Users\<username>\CA PAM Client\runtime-17.0.13_11\bin\java.exe -version
openjdk version "17.0.13" 2024-10-15
OpenJDK Runtime Environment Temurin-17.0.13+11 (build 17.0.13+11)
OpenJDK 64-Bit Server VM Temurin-17.0.13+11 (build 17.0.13+11, mixed mode, sharing)