Upgraded to new version of Desktop Client Unable to Download Applications now.
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Upgraded to new version of Desktop Client Unable to Download Applications now.

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Article ID: 266315

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Updated On:

Products

CA Workload Automation DE

Issue/Introduction

After upgrading to the new version of ESP dSeries Workload Automation Desktop Client (Version 12.3) I am unable to download applications.

 

 

Environment

Release : 12.3

Cause

Due to some corruption of the users local workspace (workspace-CAWA folder), located in the C:\Users\your_user_account\ folder on your local machine.

The below error was identified in the workspace-CAWA\.metadata\.log file which indicates a Null Pointer Exception. Thus, resulting in the job not being downloaded and the error being displayed in the Console output within Desktop Client.

!ENTRY org.eclipse.core.jobs 4 2 2023-05-18 13:40:48.291
!MESSAGE An internal error occurred during: "Download applications from server DEV 12.3 (XXXXXXXXXXXXXXXX:7500)".
!STACK 0
java.lang.NullPointerException
    at com.ca.wa.desktop.editor.ui.actions.ApplicationOperations.isApplOpen(ApplicationOperations.java:615)
    at com.ca.wa.desktop.editor.ui.actions.ApplicationOperations.download(ApplicationOperations.java:2188)
    at com.ca.wa.desktop.editor.ui.actions.multi.DownloadMultiApplicationAction$2.run(DownloadMultiApplicationAction.java:144)
    at com.ca.wa.desktop.ui.services.UIProgressMonitorService$RunJobOperation$1$1.run(UIProgressMonitorService.java:201)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Resolution

  • Disconnect and completely close out the Desktop Client.
  • Navigate to C:\Users\your_user_account\
  • Create backup of user workspace-CAWA folder.
  • Delete the original workpspace-CAWA folder.
  • Launch Desktop Client and redefine your connection to server.
  • Login and attempt to download the job.