Symantec Management Agent failing to connect to task server installed on SMP
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Symantec Management Agent failing to connect to task server installed on SMP

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Article ID: 266046

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Updated On:

Products

IT Management Suite

Issue/Introduction

Agents were once connected to Task Server installed on SMP (single server environment) but agent logs are now reporting:

'There are no registered Task Services on the SMP. This is expected in case of new SMP installation'

'Task Server Connection: There are no Task Servers available for this computer'

'Task Server Connection: Failed to get server list from NS, error: Element not found (0x80070490)'

'Task Server Connection: Failed to refresh server list or register, error: Element not found (0x80070490)'

Environment

ITMS 8.x

Cause

In one instance of this issue, it was discovered that the SMP had more than one record in 'Manage' > 'Computers' matching the name or IP address. 

It's unclear how the duplicate unhealthy records made it into the console and this alone doesn't explain the issue with Task Server.

However, the duplicate SMP records were being targeted by the scheduled Symantec Management Installation policy. This caused the actual SMP to get an agent install policy when it already had an agent. In turn, this caused the Task Server to become non-functional until it was reinstalled.

The policy was set to run once a day. If the issue is fixed after the policy runs, the same problem will happen at the same time the next day unless the policy is turned off.

Resolution

The simplest way to resolve this issue is to remove duplicate corrupt or unhealthy records from the console. The issue also may stop if the Installation Policy is disabled but this won't ensure the unhealthy records will not be mistargeted in the future.

The following KB article should assist with troubleshooting duplicate computer names and/or GUIDs:

Issues occur when using duplicate computer names and/or GUIDs