Expired or changes LDAP BIND user password causes validation failures
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Expired or changes LDAP BIND user password causes validation failures

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Article ID: 266026

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Updated On:

Products

VIP Service

Issue/Introduction

The LDAP BIND user password expires or changes, causing validation and login failures. The vipegconsole.log shows error:

ERROR "2019-09-30 14:46:48.446 GMT+0530" 10.7.131.104 vipegconsole 496594904 7584735000242959 18476 "actor=admin,text=Could not bind to the directory server.

Cause

There is an issue with the BIND username or password. 

Resolution

The Bind User DN is set in each connection within the User Store settings. These settings are stored in the conf/valconsole.properties file. If the console cannot be accessed, open this file in Notepad and locate the userstore.0.ldap.userDN= to determine the Bind User DN for each User Store connection (0 is the value of the first user store connection. Additional connection will increment by 1).

In urgent situations where the console cannot be accessed but the old password is known, an AD admin can reset the bind user password back to what it was. If policy prevents this, a new user with a matching User DN can be created and set with that password.