Agents not communicating after configuring custom agent certificates.
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Agents not communicating after configuring custom agent certificates.

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Article ID: 266017

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Endpoint Prevent

Issue/Introduction


AgentServices.ServerCommunicatorService | Failed to acquire certificate private key w/err : 2148081675
AgentServices.ServerCommunicatorService | Failed to find valid matching certificate in OS store

Cause

The errors above can be caused either by:

There is no matching certificate in the local OS store/keychain

or

The local OS store/keyring certificate that is present, does not contain the necessary private key. 

Resolution

Windows: 

1(Windows). If necessary, add the certificate snap-in to the MMC console

1(Mac). Open the Keychain Access app. 

2. Search for the appropriate local certificate. If no client authentication certificate exists, please see How are 3rd party certificates installed on DLP Endpoints

3. If the expected certificate is present, please ensure that it notes that you also have the private key for this certificate:

If the private key is missing, please contact your KPI administrator. 

 

Additional Information

For an overview of deploying 3rd party certificates to endpoint servers and agents please see the following:
https://techdocs.broadcom.com/us/en/symantec-security-software/information-security/data-loss-prevention/16-0/Manage-the-Enforce-Server/about-secure-communications-between-dlp-agents-and-endpoint-servers/configuring-endpoint-prevent-servers-to-use-custom-certificates.html