Enforce is unable to release messages from Email Quarantine
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Enforce is unable to release messages from Email Quarantine

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Article ID: 265856

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Updated On:

Products

Data Loss Prevention Cloud Service for Email Data Loss Prevention

Issue/Introduction

Messages are not going to Quarantine.

It informs that there is no email message and does not release.

The following may be logged in the Tomcat (localhost) log:

09 mai 2023 13:32:30,499- Thread: 184804 SEVERE [com.symantec.dlp.emailquarantine.EmailQuarantineService] Failed to release messages from email quarantine

Cause:

com.symantec.dlp.emailquarantine.client.EmailQuarantineApiException: Failed to invoke email quarantine API. Url: https://api.eu.quarantine.symantec.com/v1/mails/release, Request body: {"options":{"encrypt":false},"mail_list":["52269603273302aa7d0834bf2fafb16706cff2f988a26e33d6d8ebbf28de275b","bf0e8c337012c5a6a39b081681c1b4619ab63f3fb81c18930fac804dc6d58d16"]}com.symantec.dlp.emailquarantine.client.EmailQuarantineApiException: Failed to invoke email quarantine API. Url: https://api.eu.quarantine.symantec.com/v1/mails/release, Request body: {"options":{"encrypt":false},"mail_list":["52269603273302aa7d0834bf2fafb16706cff2f988a26e33d6d8ebbf28de275b","bf0e8c337012c5a6a39b081681c1b4619ab63f3fb81c18930fac804dc6d58d16"]}
...
Caused by: org.springframework.web.client.HttpServerErrorException: 500 Internal Server Error

Environment

Release : 15.8+

DLP Cloud Service for Email

Cause

The following setting was enabled in the "Network Prevent: Modify SMTP Message" Response Rule which was used to enact the Quarantine rule:

  • "Enable Email Quarantine Connect (Requires Symantec Messaging Gateway)"

As is implied above, the option for Email Quarantine Connect is only possible when using Symantec Messaging Gateway (SMG) with DLP.

However, SMG is only supported with DLP when using Network Prevent for Email (in a Reflecting mode configuration).

It is not a supported MTA for the DLP Cloud Service for Email - thus, anyone who uses the CDS for Email should not implement that checkbox in their Response Rule for quarantining of messages.

 

Resolution

Remove the tick mark which is turning on this feature:

  • "Enable Email Quarantine Connect (Requires Symantec Messaging Gateway)"

Any messages quarantined after making that change should be able to use the "Release from Quarantine" Manual response rule afterward.

 

Additional Information

For more information about setting up a quarantine function in the DLP Cloud Service for Email, see this KB:

Where do I find the Service URL and User ID for Email Quarantine feature in the Cloud Service for Email?