We are seeing hundreds of "Invalid Collection" informational messages in the SMP logs
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We are seeing hundreds of "Invalid Collection" informational messages in the SMP logs

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Article ID: 265851

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

In the SMP logs, te following informational message is seen:

"Invalid collection definition query found for collection '<NAME OF FILTER>t' (<GUID OF FILTER>). Incorrect number of columns returned from the query. 1 GUID column is expected, but 2 is found. Collection membership update will ignore the other columns and continue with the operation."

Environment

ITMS 8.x

Cause

This appears when custom filters are created using the Query Builder functionality. The Query Builder will include a GUID in the SQL parameters section of the filter as expected, and a NAME attribute which is not needed and this is what is causing the informational message to be added to the logs. 

Filters require a GUID attribute, and any other attributes are ignored. The filter will otherwise work as expected, and this message does not indicate an issue with filter functionality.

Steps to reproduce:

  1. Right-click any folder in Manage > Filters and select New > Filter.
  2. In the Filter Definition dropdown, change it to Query Mode: Query Builder
  3. View the Fields tab and note the Name attribute is defined
  4. View the Resolved Query tab and note the Name attribute is NOT present
  5. Click Save changes
  6. Click Update Membership
  7. Open Altiris Log Viewer and note the informational message

When these filters are used in a policy, this filter membership is updated, and you will see the message when one of the resource membership update tasks runs. If not in a policy, filters can be updated using a built-in task, and if run on a schedule, you will see this message when the filter update task runs. 

Resolution

This may be addressed in a future release of the IT Management Suite. 

If desired, you can edit the filter(s) and remove all fields except the GUID field by following the steps below:

  • Select the desired filter and click the Edit button in the upper right corner.
  • Navigate to the Fields tab under Filter Definition.
  • Highlight the [Computer].[NAME] (and any other desired fields except [Computer].[GUID]) and click the Red X to delete the field(s)
  • Click Save Changes at the bottom. 

Additional Information