Post Timeout Clarity throws Error
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Post Timeout Clarity throws Error

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Article ID: 265754

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When a timeout occurs and a user tries to open a link in Classic Clarity in a new tab

Steps to Reproduce:

  1. Configure Clarity to use SSO using SAML 2.0
  2. Set the Clarity Minutes Of Inactivity Until Logout to 1 minute under Administration --> General Settings --> System Options
  3. Login to Classic Clarity UX and navigate to the Projects List Page.
  4. Wait a minute for your session to timeout
  5. Right click a project name and open the link in a new tab

Expected Result: Expected to be re-directed to the timeout URL or error URL depending on how Clarity is configured.

Actual Result: User gets the above error message 

Note: This can happen on any page in classic UX and not necessary project list page 

Environment

Release : 16.1.1

Cause

The problem is that when the new tab is opened application is not finding the active session. The SAMLFilter is rightly detecting the timeout condition and is trying the send a response resulting in client side error.

This is tracked under  DE69855

 

Resolution

Workaround:

  • Till DE69855 is fixed, request the user to refresh the browser and hit the clarity URL again 
  • DE69855 is fixed in upcoming release16.1.3 as well as backported to 16.1.2 Patch 1