Migration from JBoss EAP 6.4 to JBoss EAP 7.2 ear folder's not copied
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Migration from JBoss EAP 6.4 to JBoss EAP 7.2 ear folder's not copied

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Article ID: 265595

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

We performed a 14.3 version install on JBoss EAP 6.4 and upgraded the installation to CP3 version. In anticipation of a future migration to version 14.4, the migration from JBossEAP 6.4 to JBossEAP 7.2 was performed using the migration tool present on JBossEAP 7.2. The migration was successful, but there is a failure in the IDM startup phase.

The iam_im.ear file is not deployed and the following appears in the "iam_im.ear.ear.failed" file:

"{\"WFLYCTL0080: Failed services\" => {
    \"jboss.deployment.subunit.\\\"iam_im.ear\\\".\\\"iam_im_identityminder_ejb.jar\\\".PARSE\" => \"WFLYSRV0153: Failed to process phase PARSE of subdeployment \\\"iam_im_identityminder_ejb.jar\\\" of deployment \\\"iam_im.ear\\\"
    Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found\",
    \"jboss.deployment.subunit.\\\"iam_im.ear\\\".\\\"iam_im_wpServer.jar\\\".PARSE\" => \"WFLYSRV0153: Failed to process phase PARSE of subdeployment \\\"iam_im_wpServer.jar\\\" of deployment \\\"iam_im.ear\\\"
    Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found\"
}}"

Environment

Release : 14.3

Cause

Customer migrated IM 14.3 CP3 from Jboss 6.4 to Jboss 7.2.

The migration tool did not migrate any files from  

Jboss 6.4 Home / standalone/deployments 

to

 Jboss 7.2 Home / standalone/deployments

IM on Jboss 6.4 was not deployed (never started) which caused the issue with migration.

Resolution

 

Steps to fix the issue:

1. Delete 7.2 Jboss folder with all subfolders.

2. Make sure IM on 6.4 Jboss is started, working and you are able to login to it.

3. Make sure iam_im.ear.deployed and castylesr5.1.1.ear.deployed 
file in Jboss 6.4 Home / standalone/deployments exists.

4. Stop IM.

5. Unzip Jboss 7.2

6. Run the migration tool again pointing to the new Jboss 7.2 folder.

7. Perform after migration steps. https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-3/Release-Notes/Support-for-JBoss-EAP-7-2-and-WildFly-15-0-x.html#concept.dita_4bd00041-b49f-491c-9890-9aa876dacb91_ManualPerformanceSettingsPostMigration 

8. Everything should be working now.

Additional Information

Make sure iam_im.ear.deployed and castylesr5.1.1.ear.deployed file in Jboss 6.4 Home / standalone/deployments exists before migration.