Error message issued when perform update the scheduled CA application
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Error message issued when perform update the scheduled CA application

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Article ID: 265591

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Updated On:

Products

CA Workload Automation DE

Issue/Introduction

Error message issued when performing update on the scheduled CA application flow, then can't perform any update, have to force complete the CA application.

 [Fri May 05 12:18:07 UTC 2023] [dseries] - The command COMPLETE for job TESTAPPLICATION.2.TESTJOB cannot be issued because a reason for the command was not specified.
[Fri May 05 12:24:01 UTC 2023] [dseries] - Retrieve SUNDRY WorkstationUserProfile.SCHEDMASTER.xml
[Fri May 05 12:28:24 UTC 2023] [dseries] - MGRMSG . . . . TESTJOB/TESTAPPLICATION.2/MAIN ACTION COMPLETE
[Fri May 05 12:28:24 UTC 2023] [dseries] - The command COMPLETE for job TESTAPPLICATION.2.TESTJOB cannot be issued because a reason for the command was not specified."

Environment

Release : 12.3



Cause

Identified that the Application property has check box enabled for;

"Required Reason for job commands"

 

Resolution

If an Application has below setting checked "Required Reason for job commands". the "Reason" field in the job is mandatory.

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=n5prHbnOR1yhP6g7mRJyaQ==

And either complete or reset

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=nZHl9+Et4boK99WTZQVhvA==

If no Reason is specified, you will expect to see these messages:

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=IlQPZbPQiJLRMKY09HY3EA==

Please uncheck the box for specifying reason to avoid this feature.

To avoid those messages need to checkout the checkbox for "Required Reason for job commands"