OC stops running reports after a few days
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OC stops running reports after a few days

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Article ID: 265545

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

 

What we have found, is that when the OC sessions start experiencing a "alarm retrieve errors" in the console, we are getting the following errors in ems and alarmviewer-api logs.

2022-11-16 13:55:09.413 ERROR [AlarmServiceImpl.getAlarmsWithoutMatchesFilter:1143] Error in getAlarmsFromDB : com.firehunter.ump.exceptions.DataFactoryException: Cannot get a connection, pool error Timeout waiting for idle object...

 

Environment

Release : 20.4 up to CU7

Cause

exhausted connection pool to database

Resolution

  1. Deactivate wasp probe on OperatorConsole server.
  2. Backup file [UIM Install Folder]\probes\service\wasp\lib\wasp-core.jar to some temporary folder.
  3. Delete the file wasp-core.jar located in [UIM Install Folder]\probes\service\wasp\lib
  4. Rename the attached file wasp-core-20.4.6-20230505.190255-33.jar file to wasp-core.jar
  5. Copy the attached file wasp-core.jar into [UIM Install Folder]\probes\service\wasp\lib folder. 
  6. Activate wasp on OperatorConsole server.

Attachments

1683558772706__wasp-core-20.4.6-20230505.190255-33.jar get_app