Oracle Database configuration not showing as available in CSA
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Oracle Database configuration not showing as available in CSA

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Article ID: 265473

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

CSA DB configuration not showing as available. 

CSA accepts database settings using a server name + db service name + port, but removes the port. 
After restarting services, noted that database was still not available.

Environment

Release : 16.1.1

Cause

Noticed mismatch between JDBC url used in the CSA vs properties.xml

url="jdbc:oracle:thin:@localhost"  (properties.xml)

actual url: jdbc:oracle:thin:@localhost:1521/XXX

Resolution

 

Ran the following steps to get the DB turn as available in CSA

  1. Updating URL property directly in the properties.xml
  2. Restart clarity service