Cannot save change of Self Registered Access Profile, error CCA-PL-3559
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Cannot save change of Self Registered Access Profile, error CCA-PL-3559

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Article ID: 265377

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Updated On:

Products

CA Configuration Automation

Issue/Introduction

When trying to configure the system created access profiles named 'SSH', to assign it to the deployment of 
agents on servers with Linux and Unix platforms, it does not allow to save the configuration change. Previously 
it did allowed to do it.

Environment

Configuration Automation - All versions

Cause

The access profile named "SSH" you're trying to edit has already discovered at least one server.

You could saved previously the change in the access profile named "SSH" because it hadn't discovered
any server before. So, it used the configuration you changed to discover a server.  If you go to the Servers
screeen you should see one server discovered with that Access Profile named "SSH" that you configured.
You may want to run again a new discovery of this server or refresh it, but if it allowed you to change the 
access profile it would fail, so why it cannot be changed as it's already associated to a discovered server. 

 

Resolution

If you need to discover new servers with a similar access profile make a copy with a different name to edit 
and save it. The new access profile can be used to discover new servers. 

So, you should select that profile name SSH under Access Profile, then in Select Action choose
the option Copy Profile and give a different name to it and edit the copy. 


You may try also to delete the server discovered by that access profile named SSH which used the 
Agent Mode -> Self-Registered Agent.

 

Additional Information

 

CCA-PL-3559 Cannot edit <accessprofilename> Self Registered Access Profile.