Getting message MIM0664I after applying maintenance
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Getting message MIM0664I after applying maintenance

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Article ID: 265372

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Updated On:

Products

MIM Resource Sharing (MIM)

Issue/Introduction

Maintenance was applied  on two sandbox systems.

MIM log is now showing
MIM0664I CA MIM REGPROD  service failure; RC=X'00000028' RSN=X'00000004'

both in MIMGR and MIA.

This is not showing up on a 3rd test system where maintenance was not applied.

The message does not show up in a google search.
What is the problem, and how can it be corrected?

Environment

Release : 12.5

Cause

The MIM0664I message was introduced with PTF LU07829 to exploit a new feature facilitated by Common Services called IBM Feature Registration Service (FRS).

Resolution

This is an informational message. 

Aside the PTF APPLY, nothing needs to be defined or changed within MIM itself.

Looking closer at the MIM0664I message description, it shows
    RC=28 (40) RSN=4 The Feature Registration common service is not installed on this system.
    RC=28 (40) RSN=8 The Feature Registration common service requires z/OS 2.3 or higher.

So in this case it is notifying you that this is not installed in Common Services at your site.

 

Additional Information

If you want to look into utilizing the IBM Function Registry, the following doc will be helpful.

The MIM doc outlines the purpose of this message in the section on View IBM Function Registry for z/OS Data 

Use of this feature depends on  corresponding PTFs and configuration in Common Services r15.
The feature usage and setup within Common Services is described in the Common Services doc under Use the Feature Registration Service.
Please also review related Common Services KD 257770