Service Catalog error AHD03325:getBopsid failed
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Service Catalog error AHD03325:getBopsid failed

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Article ID: 265351

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Updated On:

Products

CA Service Catalog

Issue/Introduction

The following error appears in view.log:

INFO  [https-jsse-nio-7443-exec-10] [WPFServlet] END: Time taken for GET request, Node=icguinode.launchsdmclient&sh=3l%2FkCyr9gXwdOiTWDk7PziLscQQ%3D&Args=https&Args=<hostname>&Args=8443&Args=/CAisd/pdmweb.exe&Args=OP%3DSHOW_DETAIL%2BPERSID%3Dcr%3A400701 is:215

ERROR [https-jsse-nio-7443-exec-6] [CPortal] Error occurred in getSDMClientURL: AHD03325:getBopsid failed
org.apache.axis.AxisFault: AHD03325:getBopsid failed
    at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:221) ~[axis.jar:?]

For the user with the Data partition assigned (directly or through the role) the window to open the SDM ticket keeps trying to load.

 

 

Environment

Service Management 17.3 and higher

Cause

The issue occurs due to a Data Partition with Constraint Type = View | Table name: ca_contact and some constraints (ie: type is null).

Resolution

There are 2 options:

Option 1. Add [email protected] to the constraint type = View | Table Name = ca_contact

Option 2. Disable the Data Partition Constraint