Cannot bind to AWS Active Directory
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Cannot bind to AWS Active Directory

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Article ID: 265325

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

PAM Admin is using a valid AWS Certificate, but it is not binding successful because the certificate doesn't account for the IP Address.  

Environment

Release : 4.0.x and 4.1.x

Component: PRIVILEGED ACCESS MANAGEMENT

Cause

PAM AWS and Azure deployments, the DNS servers of the hosting platform are displayed here, and cannot be changed.

The account that is integrated into AWS most likely didn't have access to their current DNS Server which was blank.

Resolution

The certificate was built with only the FQDN (example: server1.example.com) = > which wasn't resolvable.  Therefore we:

  • Updated the Target Device to use the FQDN for Hostname and Address
  • Then went into the PAM UI >> Network >> Host File Entry

and added the LDAP server in there.

We then validated the Active Directory Admin password successfully and also imported an LDAP Groups as a User Group successfully.