JCS Upgrade Failure on Identity Manager 14.4 CP2
search cancel

JCS Upgrade Failure on Identity Manager 14.4 CP2

book

Article ID: 265289

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

During a JCS upgrade you may encounter the following error message in the log:

err, Error importing LDIF file(s) to Provisioning Server. The Provisioning Server may be missing connector information or have unavailable tenants.  Look at the log file /tmp/im_connector_server_install.log for details.
 Install, com.ca.etrust.install.admin.connectorserver.SOAConfigureJCS, err, ProductException: (error code = -1; message="Error importing LDIF file(s) to Provisioning Server. The Provisioning Server may be missing connector information or have unavailable tenants.")
STACK_TRACE: 14

Environment

Release : 14.4 CP2
Component : Identity Manager
OS : Linux

Cause

The issue occurs if, when prompted during installation, you select “Yes” to the question:

“Do you wish to copy the data snapshot from a Connector Server?”

Resolution

When asked “Do you wish to copy the data snapshot from a Connector Server?”, select “No” instead of “Yes.” This prevents the error from occurring during the upgrade process.