CADZSPLx task is unresponsive - Reports not collected from JES or processed by Dispatch
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CADZSPLx task is unresponsive - Reports not collected from JES or processed by Dispatch

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Article ID: 264862

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Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

- Reports are sitting out in the JES queue and are not being processed by the CADZSPLx, SAPI or Dispatch tasks.
- The CADZSPLx task appears to be active, however, when we try to start a SAPI task such as SAPIRPI1, the CADSZAPx task never starts.
- No messages of any kind are being received that indicate a problem with the CADZSPLx task, or when we try to start the SAPI tasks. 
- We have tried issuing the /F SPLx,CLOSE as well as the /F SPLx,CLOSE IMM commands however there is no acknowledgement from the CADZSPLx task that any commands are being issued against it.
- We tried both a CANCEL and FORCE CANCEL command against the CADZSPLx task but it still will not come down.

Is there a command or method of FORCING the CADZSPLx task to come down?

Environment

Release : 11.7, CADDSPLx, CADZSPLx, FORCE, CANCEL, UNRESPONSIVE

Cause

Root cause of the CADZSPLx  tasks unresponsive state is unknown.

Resolution

- We issued a /nnnn 99STOPCADS command against the outstanding reply number to bring down Dispatch.

- To force cancel the CADZSPLx task we issued a FORCE CADZSPLx,ARM command, which brought the unresponsive task down.

- We restarted CADZSPLx using a /S CADDSPL1,,,FORCE command to avoid receiving possible "ALREADY ACTIVE" messages.

- We restarted Dispatch.

After completing the above process, everything appears to be back to normal. All necessary task are active and working. Reports are now being collected from JES and processed successfully.