Post CU6/CU7 upgrade - Unable to see data in OC
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Post CU6/CU7 upgrade - Unable to see data in OC

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Article ID: 264738

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

After upgrade from previous releases of DX UIM to 20.4 CU6/CU7. The Alarms, Alarm Policy, Groups view, and Inventory view does not display any records.

Environment

  • Database: MS SQL Server database on Windows
  • DX UIM Server and OC are hosted on CentOS8 
  • Release: UIM 20.4, CU6/CU7
  • Component : Operator Console

Cause

hibernate-core V5.4.33.Final component on Centos8 OS is incompatible to connect with MS Sql Server hosted on Windows OS

Resolution

Workaround :

  • Downgrade the hibernate-core jar 5.4.33.Final to 5.3.7.Final in the following locations on all operator console instances:
    <InstallDir>\probes\service\wasp\lib\ump
    <InstallDir>\probes\service\wasp\lib\services
    <InstallDir>\probes\service\wasp\webapps\operatorconsole_portlet\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\slm\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\policy_management_ws\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\accountadmin\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\reportscheduler\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\rest\WEB-INF\lib
    <InstallDir>\probes\service\wasp\webapps\uimapi\WEB-INF\lib
  • Restart the OC robot wasp to resolve the issue