Integration with NIM (Normalized Integration Management) with Service Now (SNOW) and OPS/MVS .
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Integration with NIM (Normalized Integration Management) with Service Now (SNOW) and OPS/MVS .

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Article ID: 264734

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Updated On:

Products

OPS/MVS Event Management & Automation

Issue/Introduction

I am looking at the REST API integration with SNOW in the README section of the manual.
It indicates there is a new field called "IsRestServiceEnabled" which has been added to the configurations detail page.
There is an image of this in the manual but my configuration page for SNOW does not have this option.

Environment

NIM (Normalized Integration Management) R3.2
OPS/MVS R14.0
Service Now

Cause

When dealing with Web Pages and configuration it can be helpful to clear browser data regularly until everything is working.
Bad data can be cached which can delay testing. 

 

Resolution

The missing field was corrected with the latest version of 'ca-nim-sm.war' file. 

A sample configuration for NIM to Service Now which successfully created an Incident in Service Now:
The final test configuration was:
{
  "assigneeGroup":"Operations Automation",
  "description":"CA NIM-SM TEST AUTO INCIDENT GENERATION",
  "severity":"Low",
  "name":"CA NIM Short description field set here",
  "category":"Alert",
  "subCategory":"Monitoring Alert",
  "affectedCIID":"CA-OPSMVS-DEV",
  "affectedEndUserID":"<valid user id>"
}