NTP Error on Appneta Server - Connectivity Tests Successful - sys.peer
search cancel

NTP Error on Appneta Server - Connectivity Tests Successful - sys.peer

book

Article ID: 264499

calendar_today

Updated On:

Products

AppNeta DX NetOps

Issue/Introduction

Appneta Portal: Seeing Monitoring point error flag showing NTP Errors:

Webadmin: NTP Server is in sys.peer condition and NTP Sychronized - Yes.

Cause

NTP Traffic not allowed in both directions. This typically happens when Outbound is allowed, but Inbound is blocked on UDP Port 123

Resolution

Run the following command from CLI: /opt/pathview/lib/python3/Pathview/util/getntpstatus.py -v

 

Look for an error similar to the one below:

 

ntpquery.getntpstatus: Apr 06 2023 21:18:27 [INFO] Querying servers: ['216.218.192.202', '132.163.4.103', '129.6.15.28', '209.51.161.238', '129.69.1.153', '193.67.79.202', '150.101.254.110', '223.255.185.2', '200.20.186.76']
ntpquery.getntpstatus: Apr 06 2023 21:18:37 [ERROR] ntpdate failed (code=1),  6 Apr 21:18:27 ntpdate[21662]: ntpdate [email protected] (1)

 

Actual Fix:

Allow Inbound/Outbound Traffic on Port 123 (UDP)