In our prod environment every day we are getting 403 forbidden errors for few applications
search cancel

In our prod environment every day we are getting 403 forbidden errors for few applications

book

Article ID: 264396

calendar_today

Updated On:

Products

CA API Developer Portal

Issue/Introduction

In our prod environment, every day we are getting 403 forbidden errors for few applications while accessing the few API end points. Even API end points are assigned to those applications but still we are getting 403 forbidden errors.

We have two data centers one EDC and another one is WTC. Same API end point is working in one data center and it is not working in another data center. Request and application and database are same for both data centers.

Portal syncs are working fine. 

Please let us know how to fix this issue.

Example end point

organizations:  ORGName -

service

/MySampleService [/MySampleService]

Error: 403

Occurrences 1195

 

Environment

Release : 10.0

Cause

Race condition resulted in the error 

Resolution

It’s expected to be addressed in Portal 5.2. 

There is a race condition in 5.0.2 whereby one could add/update the APIs assigned to an Application and in the subsequent deployment flow, a GW might actually call back to Portal to get the deployment details - before the update of the App is actually committed. With this the GW would get stale data with the wrong set of APIs that are associated with the App. 

Deployment logic and transaction boundaries were completely updated for 5.2 to address all the race conditions that were showing up.