AppNeta Monitoring Point Upgrade Error "Upgrade Failed: Failed to upgrade: Failed to start an upgrade because one is already running."
search cancel

AppNeta Monitoring Point Upgrade Error "Upgrade Failed: Failed to upgrade: Failed to start an upgrade because one is already running."

book

Article ID: 264363

calendar_today

Updated On:

Products

AppNeta DX NetOps

Issue/Introduction

Occasionally Monitoring Point Upgrades will fail with the error message "Upgrade Failed: Failed to upgrade: Failed to start an upgrade because one is already running.".

Cause

This is typically caused by either a network issue or a file system error during a previous upgrade attempt and can typically be resolved easily with the following steps.

Resolution

Run the follow two commands in order and then run the Upgrade Now option from Manage Monitoring Points again:

  1. SSH into the Monitoring Points command line.
  2. Run the following three commands with sudo privileges (admin user password) :
    1. sudo rm /var/lib/pathview/software-update/parse-offset
    2. sudo rm /var/lib/pathview/software-update/software-update-status
    3. sudo reboot
  3. Once the Reboot has completed you should be able to re-run the Monitoring Point upgrade and have it succeed.

If the monitoring point continues to fail it's upgrade attempt, please submit a Support Case if one is not already open.