Service Catalog could not reserve enough space for <value>KB object heap
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Service Catalog could not reserve enough space for <value>KB object heap

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Article ID: 264131

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

After upgrading CA Service Catalog from previous version, the catalog and accounting services won't start.

Following errors show in AccountingService.log:

STATUS | wrapper  | <timestamp> | Launching a JVM...
INFO   | jvm 5    | <timestamp> | Error occurred during initialization of VM
INFO   | jvm 5    | <timestamp> | Could not reserve enough space for 2097152KB object heap
INFO   | jvm 5    | <timestamp> | OpenJDK Client VM warning: ignoring option PermSize=128m; support was removed in 8.0
INFO   | jvm 5    | <timestamp> | OpenJDK Client VM warning: ignoring option MaxPermSize=512m; support was removed in 8.0
INFO   | jvm 5    | <timestamp> | OpenJDK Client VM warning: ignoring option UseSplitVerifier; support was removed in 8.0
ERROR  | wrapper  | <timestamp> | JVM exited while loading the application.

Environment

Service Catalog 17.3 and higher

Cause

This error indicates the system does not have enough RAM (2 GB) to allocate to the Java virtual machine.

Resolution

Reduce the Xmx for the Catalog and Accounting services:

For Service Accounting service:

Change the value set for wrapper.java.maxmemory in the Service Catalog\accounting\conf\accountingService.conf file. Ensure the maxmemory is equal to or greater than the wrapper.java.initmemory

For Service Catalog service:

Change the value set for wrapper.java.maxmemory in the Service Catalog\view\conf\viewService.conf file. Ensure the maxmemory is equal to or greater than the wrapper.java.initmemory

After these changes, make sure to (re)start the Service Catalog/Accounting services.