Unable to Apply Agent Based Inventory Targets
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Unable to Apply Agent Based Inventory Targets

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Article ID: 264119

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Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading to ITMS 8.7, it was noticed that if you try to add a target to an Agent-based inventory policy, when selecting the target from the list and adds it, it doesn't actually apply. However, if you then select the target via the recently used targets page, it will apply without an issue.

Steps to reproduce:

1) Create a target (Manage ->Computers ->Targets), and add a group of computers to it you want to gather inventory from.
2) Click Actions -> Inventory -> Agent-based in the console menu.
3) Expand Discovery and Inventory -> Inventory on the left side, and either create or select an existing inventory policy.
4) Click "Apply to" and select "Targets".
Locate your target in the list, highlight it, and click the right arrow to move it into the list of selected targets, then click ok.

The expected result is that the target is added under the Applies To/Compliance window. However, that doesn't occur, and the target is not applied.

This behavior and it's present in both our old/legacy 8.6 RU3 console as well as 8.7. This is reproducible using the latest version of both Microsoft Edge and Google Chrome (112 as of the time of this ticket).

Environment

ITMS 8.6 RU3, 8.7

Cause

Known issue. There is an issue with JS XML/HTML node parsing, which needs to be fixed.

Resolution

This issue was resolved in our ITMS 8.7 RU1 release.

Workaround:

If you click 'Save' and refresh the page, the target is still not applied. However, if you then click "Apply to" and then hover over "Recently used targets", you will see the target you just attempted to previously apply, which you can then select, then hit save. This will then properly add the target to the inventory policy.