IM Failed To Start - WFLYDS0011: The deployment scanner found a directory named META-INF that was not inside a directory whose name ends with .ear, .jar, .rar, .sar or .war.
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IM Failed To Start - WFLYDS0011: The deployment scanner found a directory named META-INF that was not inside a directory whose name ends with .ear, .jar, .rar, .sar or .war.

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Article ID: 263968

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

JBoss fails to start properly and deploy IM and the JBoss server log shows the following error:

ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) WFLYDS0011: The deployment scanner found a directory named META-INF that was not inside a directory whose name ends with .ear, .jar, .rar, .sar or .war. This is likely the result of unzipping an archive directly inside the <JBOSS_HOME>\standalone\deployments directory, which is a user error. The META-INF directory will not be scanned for deployments, but it is possible that the scanner may find other files from the unzipped archive and attempt to deploy them, leading to errors.

Environment

All Identity Manager

Cause

In looking at the <JBOSS_HOME>\standalone\deployments folder I see there are backup folders such as "iam_im.ear - backup" which is causing a conflict. You should not be keeping backup jars/classes/files within the JBoss folders.

Resolution

1. Stop JBoss
2. Delete the contents inside the JBoss \standalone\tmp folder and \standalone\log folder
3. Rename the marker files so you only have castylesr5.1.1.ear.dodeploy and iam_im.ear.dodeploy in the JBoss standalone\deployments folder
4. Delete any backup folders/files within JBoss such as "iam_im.ear - backup" folder in the JBoss standalone\deployments folder in this example
5. Start JBoss