url_response probe is inactive
search cancel

url_response probe is inactive

book

Article ID: 263823

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After configuring a new profile for URL in the url_response probe, the metrics are unavailable in the operator console's inventory.  The following symptoms might be seen: 

 

- The selected QOS_MESSAGES are visible in the dr.nimbus tool

- the "insert data" messages, are visible in the data_engine.log file, but there are no messages with "complete: yes" status and the data is not in the S_QOS_DATA  table 

 

 

Environment

Release : 20.4

url_response 4.50 ( the issue may happen for other probe versions as well) 

robot 9.36 

Cause

The exact root cause of this issue was not diagnosed but seemed like something was stuck in the database, which was causing problems with creating new QOS entries for the specific table_id / ci_metric_id.

Resolution

The problem was resolved by:

 

- clearing niscache of the affected robot (where url_response probe has been deployed) 

- resetting device_id (also of the affected robot) 

- restarting data_engine on the primary HUB 

 

After the above steps, the data started being inserted into the database