SMTP Status: 421 4.4.4 [internal] domain does not resolve
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Article ID: 263759
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Updated On:
Products
Messaging Gateway
Issue/Introduction
The Messaging Gateway (SMG) Message Audit Logs show the following error / status when attempting to deliver some or all messages:
421 4.4.4 [internal] domain does not resolve
Cause
Messaging Gateway is unable to resolve the recipient domain's MX or A records in the DNS. This may be due to one or more of the following:
- The records do not exist in the DNS
- The configured DNS servers in Administration > Configuration > host > DNS / Time are either inaccessible or not responding as expected
- Messaging Gateway has been configured to use one or more public, rate limited DNS servers
- DNS servers are responding slowly to queries.
Resolution
Confirm that the DNS servers configured in Administration > Configuration > host > DNS / Time are responding as expected
- Log into the Messaging Gateway command line as admin
- Query the configured nameserver directly for a known good domain by appending the nameserver IP to the nslookup command. For example:
nslookup -type=mx broadcom.com 10.0.0.53
- Repeat this for each nameserver configured in Administration > Configuration > host > DNS / Time to ensure that all nameservers are responsive
Confirm that the expected records are in the DNS
- Log into the Messaging Gateway command line as admin
- Query the DNS for the MX and A records for the destination domain:
nslookup -type=mx example.com
- A NXDOMAIN response means that the expected MX or A record does not exist in the DNS
nslookup -type=mx example.com
Server: 127.0.0.1
Address: 127.0.0.1#53
** server can't find example.com: NXDOMAIN
Ensure that SMG is not configured to use public, rate limited DNS servers
Disable unnecessary services on SMG that generate a high volume of DNS queries, such as URL reputation and reverse DNS lookups.
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