Can't use ZOWE JES Explorer and MVS Explorer
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Can't use ZOWE JES Explorer and MVS Explorer

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Article ID: 263698

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Updated On:

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Issue/Introduction

Can't use some of Zowe's applications such as JES Explorer and MVS Explorer after login to zowe desktop. 

Tried to open these applications, after entering username and password, got the following error:

"Unexpected token '<', "<h1>Resour"... is not valid JSON"

Cause

App-server port is used to login to desktop
https://host:app-server-port/ZLUX/plugins/org.zowe.zlux.bootstrap/web/

app-server port can be used for all other apps except JES/USS/MVS explorers
gateway port works for all the apps including JES/USS/MVS.

Resolution

Use gateway port to login to desktp, then open JES/USS/MVS explorers. 
https://zowe.externalDomains[0]:zowe.externalPort/zlux/ui/v1/

Or use the direct Desktop URL to login, then open JES/USS/MVS explorers.

https://zowe.externalDomains[0]:zowe.externalPort/zlux/ui/v1/ZLUX/plugins/org.zowe.zlux.bootstrap/web/index.html

Where:

    • zowe.externalDomains is the host on which you are running the Zowe Application Server, its the value that was assigned in the zowe configuration file.
    • zowe.externalPort is the value of Gateway port that was assigned in the zowe configuration file.

 

Or from the API Catalog, click on the Zowe Application Server tile and then use the Service Homepage link to access JES/USS/MVS explorers.