Bulk Status Report Export feature Writing in \tmp file during export
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Bulk Status Report Export feature Writing in \tmp file during export

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Article ID: 263628

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Bulk Status Report Export while exporting the status report it’s copying shell and node scripts in a /tmp location, It’s trying to execute the script in /tmp. Since the write permission is restricted for the  /tmp location the 'node' file in playwright-java-xxx folder created in /tmp is failing with permissions denied. 

 

Steps to Reproduce: 

  1. Login to clarity and navigate to Status report workspace 
  2. Export the status report 
  3. Login to server where clarity is running and observe /tmp folder 

Expected Results: During export nothing should be written in the /tmp folder and still Bulk Status Report Export functionality should work 

Actual Results: During Bulk Status Report Export files are being written in the /tmp folder and since write permission is not provided in /tmp location the Bulk Status Report Export fails to export. 

Environment

Release : 16.1.x

Cause

DE69182 The current functionality of Bulk Status Report Export invokes chrome and its chrome default behavior is to write in /tmp location and once the export is complete the written files are automatically deleted. 

This is not a defect however since multiple customer dont tend to give write permission to /tmp folder, Broadcom has decided to look into redesigning the same and provide user a prompt during installation to configure the temp folder 

Resolution

DE69182 - From 16.1.3 during install/upgrade there is a prompt asking to provide a Clarity Temporary Directory and same path will be used in order to write any temporary run time files 

Workaround till 16.1.3 

  • Provide write permission to /tmp location to the user used for running clarity services