SMPE Internet Retrieval Process - Broadcom servers available
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SMPE Internet Retrieval Process - Broadcom servers available

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Article ID: 263522

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Updated On:

Products

COMMON SERVICES FOR Z/OS

Issue/Introduction

When running multiple batch jobs for different Broadcom Mainframe products) to Receive PTFS, we lately had some errors and need to rerun the batch jobs later in the day. (Below is the error)

Is there a certain time of the day we should NOT be running these due to Broadcom being unavailable?  Todays errors listed below at 3/29/23,  01:00 - 01:02 EDST

Is there a way to run a 'CHECK' to make sure Broadcom is available, and have that as a PREREQ to our batch job stream, to prevent all batch from being unsuccessful? 
Is there a way to get a 'FAILURE' message in the JOBLOG and maybe can use OPS/MVS to help flag this, instead of the error hidden in the SMPOUT DD?

Sometimes just a couple of the jobs fail and the reruns are successful - but the reruns are all manual.

What are your suggestions to avoid us from getting involved to 'fix', what is to be an automated process? 
                                                                            
              RECEIVE ORDER(ORDERSERVER(ORDSRVR)                                
                      CLIENT(MYCLIENT)                                          
                      CONTENT(ALL))                                             
                      DELETEPKG.                                                
                                                                                
GIM68700I    ORDER ORD00488 HAS BEEN SENT TO THE SERVER AT https://eapi.broadcom.com/receiveorder.    
GIM69192S ** RECEIVE PROCESSING HAS FAILED FOR ORDER ORD00488. AN ERROR WAS FOUND IN THE RESPONSE RECEIVED FROM THE
             SERVER AT https://eapi.broadcom.com/receiveorder WHEN PROCESSING ORDER ORD00488 WITH ORDERID 1490952.
GIM69226I    faultcode = Server.Processing.DataCollectionServer.Processing.DataCollection.  
GIM69226I    faultstring = The server cannot process the request.               
GIM69226I    description = MSP0008E - CA had a temporary resource outage process
             order..                                                            
GIM20501I    RECEIVE PROCESSING IS COMPLETE. THE HIGHEST RETURN CODE WAS 12.    

Environment

Release : 15.0

Cause

Internal Broadcom Order server errors.

Resolution

Broadcom is using SMP/E Receive Order.  Broadcom cannot enhance the SMP/E to get the FAILURE messages in the JOBLOG.   
But is planniong on enhancing the generic messages so customers are informed about scheduled maintenance. 
The maintenance window is typically at 9:00 pm CST on Friday.    

The server error the clients experienced on March 29th were on internal servers, so there is nothing the clients could have run to detect these problems..
Broadcom plans to set up more health checks on our servers so that we do not have these types of failures in the future..

Also, one of the options, would be to use OPS/MVS and write the SMPOUT DD messages of the SMPE receive order job to the OPSLOG.. Via the GDI interface of OPS/MVS..

Define Generic Dat Set Interface (GDI)