A specific PDF file errors out while being uploaded to collabration tab
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A specific PDF file errors out while being uploaded to collabration tab

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Article ID: 263483

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Experiencing an error " "Unable to communicate to the PPM server. Please try again and if problem persists contact your system administrator" while uploading a specific PDF file in the Collaboration Tab. Despite the PDF file size being relatively smaller than the ones we have previously loaded, we are unable to upload it even after several attempts and other pdf files gets uploaded fine

app-ca.logs:

FATAL Date.. [http-nio-10.10.208.3-80-exec-9] niku.webglue (clarity:<someUser>:9705029__C771F119-81E7-4B61-BBEA-E9E1E0D75BE3:dms.ProjectsFileManager) Exception in page or action
java.lang.NullPointerException
    at com.niku.dms.web.FileManager.loadFolders(FileManager.java:490)
    at com.niku.dms.web.FileManager.prepareView(FileManager.java:104)
    at com.niku.webglue.GetViewPage.preparePage(GetViewPage.java:47)

HAR file shows DMS add files action not successful :

https://clarity_url/niku/nu?uitk.vxml.form=1&action=dms.ProjectsaddMultipleFileAction&uitk.session.uuid=xxx c&uitk.navigation.location=Workspace&uitk.navigation.parent.location=Workspace&uitk.navigation.last.workspace.action=dms.ProjectsaddMultipleFiles

Environment

Release :15.9.1

Cause

Issue with Load balancer configuration that is blocking company sensitive PDFs to be uploaded. 

Resolution

File upload was successful from standalone application URL. 

IT security team adjusts Load balancer configuration to allow company sensitive PDFs to be uploaded.