Mobile user agent inconsistent with Safari on iPad
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Mobile user agent inconsistent with Safari on iPad

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Article ID: 263477

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Updated On:

Products

CASB Gateway Advanced

Issue/Introduction

During an iPad session the user agent is inconsistent in how it reports the user. During the same session, it varies:

Safari Mobile

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.4 Mobile/15E148 Safari/604.1

Safari

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.4 Safari/605.1.15

 

Environment

iPad mobile with user agent installed

Cause

This is caused by how Apple handles the browser settings on an iPad.

By default, the Safari browser changes between iOS and desktop modes depending on the orientation of the iPad and/or the website code. 

Resolution

Navigate to Settings > Safari > Request Desktop Website > All websites.

This setting is enabled by default but should be disabled to resolve the issue.

With this disabled, the device will remain in the iOS browser mode and you will see the proper User Agent for every session.