Missing right parenthesis error during Identity Manager startup.
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Missing right parenthesis error during Identity Manager startup.

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Article ID: 263270

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Updated On:

Products

CA Identity Suite

Issue/Introduction

The following error message is seen during IDM startup.

ERROR [com.workpoint.server.DbVerifier] (Timer-3) An exception occurred when attempting to auto-create the Workpoint database. java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

ERROR [com.workpoint.server.recordset.SmartStatement] (Timer-4) SQLException caught java.sql.SQLSyntaxErrorException: ORA-00907: missing right parenthesis

Environment

CA Identity Manager 14.4

Cause

Workpoint is pointing to the wrong database type.

Resolution

This issue can be resolved by updating the workpoint-server.properties file.

Set the following attribute:
workpoint.db.provider = oracle