User Search For Use does not show accurate results of UserGroups
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User Search For Use does not show accurate results of UserGroups

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Article ID: 263219

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The following issues may occur when performing a Search for Use on a User Object:

1) When we search for use recently created users, it will return a result of Object Search: 0 results.

This is even if the user is properly assigned to a UserGroup, as it can be seen under UserGroup Object that the user is added.

Old users are not having this kind of issue.

 

2) Another issue is that when we remove a UserGroup assignment from a user, if we do object search, it will still show that is still used on the removed UserGroup.

Environment

Release : 12.x and 21.x

Component: Automation Engine

Cause

Defect: this is an issue with the indexing of changes on users.

Resolution

Workaround:

Deleting and re-creating the Lucene index allows proper indexing of the USER data, please follow the instructions here to do so.

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine
Will be fixed in Automation.Engine 21.0.8 - Available

Additional Information

Bug ID: AE-31405

Public Description: A problem has been fixed, where the search for use on a user object did not show the usergroup references correctly.