Clarity Rally Integration Finish Date does not get transferred correctly during sync job
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Clarity Rally Integration Finish Date does not get transferred correctly during sync job

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Article ID: 263178

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When creating a Program custom investment in Clarity and you run the Sync job to sync data to Rally you see an error 'Failed in Rally' - [Validation error: Program.PlannedStartDate must be on or before end date.]. The Finish Date gets transferred during sync job which makes it incorrect in Rally.

Cause

Appears to be a time zone discrepancy. Integrations running on a Clarity server is using the Clarity server time zone since the integration Rally is likely using the Rally workspace time zone associated to the Rally API Key user. If the two time zone settings are different, then the integration may not recognize this.

Resolution

Possible workaround:
In Clarity change the Finish Date default
Go to Administration > Objects > Program (CIT) > Attributes > Finish