Last Open Date Field in Search Filter changes if set to 12:00 AM
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Last Open Date Field in Search Filter changes if set to 12:00 AM

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Article ID: 263140

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

In the search filter for requests/incidents, in the date field of the last opening, when placing the time 00:00:00 on the date, it is changing it to 23:59:59 - why is this happening?

See the same problem with all the "Latest" date fields

Latest Time to Violation
Latest Open Date
Latest Resolve Date
Latest Close date
Latest Outage Start Date
Latest Outage End Date
The "Earliest" date fields don't show this same problem.

The "Latest" date fields only show this when setting the time to 0:00 or 12:00 am.  If setting to any other time, this does not happen.

Environment

CA Service Desk Manager 17.x

Cause

It is working as designed.

The reason for this is, when you give the date and time as "03/31/2023 12:00AM", the system considers the date and time as "03/31/2023 00:00:00".  Since the time portion is zeros, we consider to search for the entire time of that day which is 03/31/2023 11:59 pm. 

This is only minute (00:00) in the 24-hour day related to latest where the comparison happens with LE (less than or equal to).

Resolution

As a workaround, if you choose one minute before (11:59 PM) or after (12:01 AM), you will not see the same problem.