PRJ-07585 error when updating the ResourceID field
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PRJ-07585 error when updating the ResourceID field

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Article ID: 263112

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

I am unable to update the ResourceID field of a user in the Clarity Administration menu. I get the following error when trying to do so:

PRJ-07585: : Unique name is read only

This happens to a single user on the Administration > Organization and Access > resources menu

The resource is not financially enabled and no other user exists with the same ResourceID

Environment

Clarity 15.9.X and 16.X

Cause

A different user profile exists for the same resource even if the ResourceID field to be updated is not in use

Resolution

Update the ResourceID field on the Home > Resource Management > Resources menu instead

In 16.1.2 this is not reproducible.