Upgrade error to version 7.0 and 6.10.10x+ if node installed in C:\Program Files (x86)
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Upgrade error to version 7.0 and 6.10.10x+ if node installed in C:\Program Files (x86)

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Article ID: 262944

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

DUAS Setup 6.10.101+ or 7.0.01 or superior on Windows finishes as OK whereas it leaves a node that cannot be started as it does not handle properly if the node had been installed in the folder "C:\Program Files (x86)\xxx"
The reason can be visible in the maintenance_debug.log:

C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\bin>call :edit_title "Upgrade log4j.xml if necessary..." 
===================================================================
"Upgrade log4j.xml if necessary..."
====================================================================
C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\bin>goto:eof

C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\bin>call :upgrade_file_log4j 
\AUTOMIC\DUAS\COMPANY_NODE\data\data_java\log4j.xml] was unexpected at this time.
C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\bin>     echo File [C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\data\data_java\log4j.xml] doesn't exist.

While starting you will get this error:

C:\Program Files (x86)\AUTOMIC\DUAS\COMPANY_NODE\bin>unistart
Instance startup procedure

checking version file consistent . . . .
Inconsistent version: 6.10.91 (binary 6.10.101)
Version file not consistent with current binaries.
Binaries are not consistent with data, your instance cannot be started.

Environment

Release : 7.00.01 and 6.10.10x

Component: Dollar Universe

Sub-Component:Dollar Universe Application Server (Node)

OS: Windows ONLY

Cause

Defect in the Windows Setup

Resolution

Workaround:

First, fix the version.dat to show the correct newer version would be to launch the command universion with the build of the version you are upgrading to, ie. for 6.10.101 the build is 048, so you would need to launch from bin:

universion -addver -build 048 U

 

For versin 7.0.01, the build is 981, so you should launch:

universion -addver -build 981 U

Then when you will launch universion -history you will see this kind of information:

C:\Program Files (x86)\AUTOMIC\DUAS\UNI610_vmstm2k1601\bin>universion -history
   ___  ____  ______   ______
  / _ \|  _ \/ ___\ \ / /  _ \
 | | | | |_) \___ \\ V /| |_) |
 | |_| |  _ < ___) || | |  __/
  \___/|_| \_\____/ |_| |_|

-------------------------------------
History of installations:
-------------------------------------
03/28/2023 10:24:54: Dollar Universe version 6.10.91 build [WINDOWS64-11] (on Oct 27 2021) (install)
-------------------------------------
Current version:
-------------------------------------
03/28/2023 11:35:18: Dollar Universe version 6.10.101 build [WINDOWS64-48] (on Jul 26 2022) (upgrade)

 

Additionally, you also have to unzip the file zoneinfo.zip manually to update the time zone files and then you can start the node again.

Solution:

Update to a fix version listed below or a newer version if available.

Fix version(s): 
Component: Application Server (Node)
Dollar Universe 7.0.11 - Planned to be released end of April 2023
Dollar Universe 6.10.111 - Planned to be released in June 2023