First time login as admin and system error found while change password
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First time login as admin and system error found while change password

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Article ID: 262730

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Logging into the Clarity UI with admin user for first time and it asks to set new password but upon trying new password it shows ERROR system error. Contact system administrator.

Tried several different new passwords with uppercase lowercase and special characters still no luck.

Environment

Release : 16.1.0

Cause

Windows drive where SQL server is full is out of space and hence Transaction log cannot grow due to which the basic update SQL query fired from the system is not able to execute against the DB. 

App-ca.logs:

ERROR  [https-openssl-nio2-443-exec-27] niku.xql2 (clarity:unknown:none:security.changePasswordFirstTimeAction) Internal Processing exception
com.niku.union.persistence.PersistenceException: 
SQL error code: 9002
Error message: The transaction log for database 'niku' is full due to 'LOG_BACKUP'.
Executed:
 UPDATE CMN_SEC_USERS SET PWD = ?, LAST_PWD_CHANGE = ?, FORCE_PWD_CHANGE = 0, SALT = ?
        WHERE UPPER(USER_NAME)=UPPER(?) 
Derived from statement:
<?xml version="1.0" encoding="UTF-8"?>
<statement location="securityPMD.xml" id="security.updateUserPWD_stmt" batchable="true" sortColumnPath="/data/header/sortInfo/@sortColumn" sortDirectionPath="/data/header/sortInfo/@sortDirection" slicePath="/data/header/pagination/sliceInfo/@slice" sliceSizePath="/data/header/pagination/sliceInfo/@sliceSize" inputSource="none" xmlns="http://schemas.niku.com/2002/pmd">
  <sql dbVendor="all" tsvTemplateAttrCode="">
    <text>
        UPDATE CMN_SEC_USERS SET PWD = ?, LAST_PWD_CHANGE = ?, FORCE_PWD_CHANGE = 0, SALT = ?
        WHERE @UPPER@(USER_NAME)=@UPPER@(?)
      </text>
    <param name="passWord" type="string" direction="IN" expressionListDelimiter=","/>
    <param replace="timestamp" direction="IN" expressionListDelimiter=","/>
    <param name="salt" type="string" direction="IN" expressionListDelimiter=","/>
    <param name="userName" type="string" direction="IN" expressionListDelimiter=","/>
  </sql>
</statement>

Referenced by:
<?xml version="1.0" encoding="UTF-8"?>
<statementRef id="security.updateUserPWD_stmt" inputSource="map" sortColumnPath="/data/header/sortInfo/@sortColumn" sortDirectionPath="/data/header/sortInfo/@sortDirection" slicePath="/data/header/pagination/sliceInfo/@slice" sliceSizePath="/data/header/pagination/sliceInfo/@sliceSize" xmlns="http://schemas.niku.com/2002/pmd"/>

Using input: 
{passWord=SomePassword, salt=SomeSalt, execute::batch=false, parameterSet=[], visitor=com.niku.xql2.XQLVisitor@682328c4, userName=admin, parameters=[null:userName:admin:, null:passWord:SomePassword:, null:salt:SomeSalt:], value=security.updateUserPWD_set}

Resolution

Increasing disk space on the windows server. 

Additional Information

Clarity: The MSSQL transaction log for the database is full, or has grown excessively