JBoss JMS persistence manager fails
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JBoss JMS persistence manager fails

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Article ID: 26272

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

When starting JBoss, exception concerning the JMS persistence manager appear:

ERROR [STDERR] java.lang.OutOfMemoryError

ERROR [org.jboss.mq.pm.jdbc2.PersistenceManager] Starting failed org.jboss.mq.SpyJMSException: Could not resolve uncommited transactions.
Message recovery may not be accurate; - nested throwable:
(java.sql.SQLException: out of memory)
at
org.jboss.mq.pm.jdbc2.PersistenceManager.resolveAllUncommitedTXs(PersistenceManager.java:336)
at
org.jboss.mq.pm.jdbc2.PersistenceManager.startService(PersistenceManager.java:1356)
at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
... ...

Environment

Release: CAIDMB99000-12.6.2-Identity Manager-B to B
Component:

Cause

This is a core JBoss issue rather than deployment related - The problem is either corrupt or too big database for the JMS persistence manager.

Resolution

1. Shutdown JBoss

2. Open the folder server\default\data\hypersonic and backup or rename the files in it.

3. Restart JBoss.

The errors should go away.

Please note that this could delete all transactions pending.

Additional Information

As per TEC489087 - We should not be using Hypersonic for JBoss JMS queue in Production systems