Devices deleted via API or GUI return within 24 hrs with new ID's.
search cancel

Devices deleted via API or GUI return within 24 hrs with new ID's.

book

Article ID: 262718

calendar_today

Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

An ongoing issue has been occurring where devices deleted via the API or GUI reappear in the PM Console with new ID's although no user created discovery profile has run.  

The devices are added back using the default domain discovery profile and the devices in question do not exist in Spectrum.

Environment

Release : 22.2

Cause

Some data sources have the option of contributing to the DA inventory.

This is enabled/disabled on the data source properties in the Console:

(screenshot is from a Spectrum data source)

Resolution

In this instance, the customer had ADA as a data source, in addition to spectrum.

The devices were being contributed by the ADA data source.

We unchecked the option to contribute inventory on the ADA data source, as the devices were no longer needed in PM.

Additional Information

We determined that ADA was adding these devices by

Get the itemid for a device by looking at the device details page in Console.

 

Login to mysql

mysql netqosportal -u netqos -p (will prompt for password)

select * from dst_device where itemid=ID-FROM-ABOVE\G

Replace ID-FROM-ABOVE with the id’s you find.

……………

*************************** 1. row ***************************

                   SourceID: 4

                    LocalID: 19540599

*************************** 2. row ***************************

                   SourceID: 11

                    LocalID: S612

***************************************

..

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/22-2/building/discovery/discovery-from-other-data-sources.html