DX APM Jboss Agent compatibility
search cancel

DX APM Jboss Agent compatibility

book

Article ID: 262665

calendar_today

Updated On:

Products

DX Application Performance Management

Issue/Introduction

We have to install Tomcat and Jboss APM agents at one of our customers environment to monitor Jboss, Wildfly and Tomcat Applications. The documentation contains a link "supported JBOSS versions" which does not point to the correct content. Can this please be solved so we can verify which versions are supported.

 

 

 

Cause

Agent Doc Link broken

Resolution

We seem to have two cases.

1) Fixed the doc bug.

2) And what you really want supported JBOSS releases

If you want a quick answer. Just look at the supported APM compatibility guide for your release. See https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/CA-Application-Performance-Management-Compatibility-Guides/2146?r=2&r=1&r=1&r=1

For example SAAS supports last time I checked (Changes based on OS, Java etc)

-JBOSS 6 & 7

- JBOSS EAP 5.2,6.3.x,6.4,7.0,7.1,7.2,7.3

-Wildfly up to 26.x

-JBOSS Data Grid 7

If that answers your question, will close this case and can do another case on the doc bug if you are interested

Link Fixed -- https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/dx-apm-agents/SaaS/java-agent/install-the-java-agent/configure-application-server-to-use-the-java-agent/jboss-as-wildfly-and-jboss-eap.html