cr:auto_assign unknown message when trying to edit a ticket in Service Desk Manager
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cr:auto_assign unknown message when trying to edit a ticket in Service Desk Manager

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Article ID: 262484

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After upgrading CA SDM to 17.3 RU20, the following error appears in the SDM UI:

cr:auto_assign unknown messge

The STDLOG shows:

spelsrvr                7160 ERROR        interp.c               583 cr::auto_assign Unknown messge.
web:local                352 ERROR        freeaccess.spl       26006  create checkin of cr:503699 failed: cr::auto_assign Unknown message.
spelsrvr                7160 ERROR        interp.c               583 cr::auto_assign Unknown messge.
web:local                352 ERROR        freeaccess.spl       26006  create checkin of cr:503699 failed: cr::auto_assign Unknown message.
spelsrvr                7160 ERROR        interp.c               583 cr::auto_assign Unknown messge.
web:local                352 ERROR        freeaccess.spl       26006  create checkin of cr:503699 failed: cr::auto_assign Unknown message.

Environment

CA Service Desk Manager 17.3 RU20

Cause

Custom/old files located in the OOTB files under NX_ROOT\bopcfg\majic

Resolution

1. Take a backup of NX_ROOT\bopcfg\majic

2. Stop SDM service

3. Remove all the files that end with .ver_old extension from NX_ROOT\bopcfg\majic

4. Remove all custom files from the NX_ROOT\bopcfg\majic and restore the original files. For 17.3 RU20, you should have a total of 59 files (you can place the custom files under site/mods folder)

6. Start SDM service