ITPAM SSL Agent cannot communicate with Orchestrator
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ITPAM SSL Agent cannot communicate with Orchestrator

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Article ID: 262465

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After converting ITPAM and load balancer to SSL and port 8443, the Orchestrator doesn't recognize the agent is active

Environment

Release : 4.3

Cause

When configured for SSL, ITPAM listens on port 443 and on port 8443.  Agent communications will go through port 443, while user interaction with the ITPAM website and UI will go through port 8443.  To test:

If you enter the url like https://OrchestratorNodeURL:443 you should see the message returned:

Request received by: Default handler for Orchestrator node: ......

If you enter the url like https://OrchestratorNodeURL:8443 you should see the ITPAM user interface.

Resolution

Configure the load balancer so that:

https://LoadBalancerURL:443/itpam forwards to https://OrchestratorNodeURL:8443

and

https://LoadBalancerURL:443 (without the "/itpam") forwards to https://OrchestratorNodeURL:443