How to upgrade a PAM SC installation with multiple PMDB when it is taking a long time
search cancel

How to upgrade a PAM SC installation with multiple PMDB when it is taking a long time

book

Article ID: 262316

calendar_today

Updated On:

Products

CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Sometimes carrying out an upgrade of a PAM SC installation with multiple PMDB is taking a long time, even if the upgrade involves just a small jump in version. For instance, from CA PAM SC 14.10.40.102 to CA PAM SC 14.10.50.61

This document provides a possible workaround

 

Environment

CA PAM SC 14.10.X

Cause

When the upgrade is performed, the upgrade script exports each PMDB to text, creates a new database in the new version and reloads the data

Sometimes this operation may take a long time to complete, especially if there is a large number of PMDB and also if there is some minor corruption in any of the databases. Under these circumstances it may be unpractical to launch the automated script, especially taking into account that between close versions of PAM SC there are just minor or no changes in DB structure.

Resolution

One possible way of working around the problem is to stop the product, move away the directory containing the PMDB policy model databases (e.g. mv /opt/CA/PAMDB /opt/CA/PAMDBsave), then perform the upgrade, which will just upgrade the binaries, and then move back the saved PAMDB (e.g. mv /opt/CA/PAMDBsave /opt/CA/PAMDB)