Not all Docker Portal containers go up
search cancel

Not all Docker Portal containers go up

book

Article ID: 262300

calendar_today

Updated On:

Products

CA API Developer Portal

Issue/Introduction

After completing an offline installation, the portal_dispatcher and portal_apim containers will not start.

From the portal_dispatcher log:

Environment

API Portal 5.1

Cause

The portal hostname and subdomain were incorrect for the apim tenant.

Resolution

- Remove the portal stack: docker stack rm portal
- From the portal database, run command: 
  update TENANT_INFO set PORTAL_HOST='apim.<SUBDOMAIN> where TENANT_ID='apim';
- From the tenant_provisioning database, run commands:
  update TENANT_DETAILS set PORTAL_HOST='apim.<SUBDOMAIN>' where TENANT_ID='apim';
  update TENANT_DETAILS set SUBDOMAIN='<SUBDOMAIN>' where TENANT_ID='apim';
- In the /etc/hosts file, instead of analytics.<SUBDOMAIN>, use apim-analytics.<SUBDOMAIN> [NOTE: This step may need to be skipped for most customers - but it seemed to work for this customer.]
- Start portal services: ./portal.sh