Altiris Deployment Agent fails to start with Error 1053 due to Service Timeout
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Altiris Deployment Agent fails to start with Error 1053 due to Service Timeout

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Article ID: 262293

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

When deploying the Altiris Deployment Agent through the Remote Agent Installer from the Ghost Solution Suite Console, the agent service starts and is running and is Active in the Ghost console. However, if trying to restart the Altiris Deployment Agent service on the client (or reboot the client) it fails to start with error:

[SC] StartService FAILED 1053: The service did not respond to the start or control request in a timely fashion.

Environment

GSS 3.3 RU10

Cause

The Dagent may take a long time to start on a slow machine exceeding the timeouts

Resolution

Original process related to this area has been improved in GSS 3.3 RU12 Release.

As a workaround (only for those prior to GSS 3.3 RU12 release) the administrator can increase timeout via ServicesPipeTimeout per the following Microsoft article:

The Windows Trace Session Manager service does not start and Event ID 7000 occurs

  1. Open Registry Editor.

  2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.

  3. Create/Modify the ServicesPipeTimeout DWORD value.