Error: ORA-12170 connection timeout
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Error: ORA-12170 connection timeout

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Article ID: 262252

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Updated On: 03-24-2025

Products

Information Centric Analytics

Issue/Introduction

When creating a new Symantec Data Loss Prevention (DLP) connection in Information Centric Analytics (ICA), the New Connection Wizard fails to save a datasource connection and returns an error message containing the following:

ORA-12170: TNS:Connect timeout occurred

Alternatively, after having previously integrated DLP with ICA, the Run Staging Procedures step (4) of both the nightly RiskFabric Processing job and the RiskFabric Intraday Processing job fail and the following errors are captured in the SQL Server Agent history log and in the Log_DataTransformation table in the RiskFabric relational database:

OLE DB provider "OraOLEDB.Oracle" for linked server "RISKFABRIC_DLP_RISKFABRIC_<hostname>_PROTECT" returned message "ORA-12170: TNS:Connect timeout occurred".

Cannot initialize the data source object of OLE DB provider "OraOLEDB.Oracle" for linked server "RISKFABRIC_DLP_RISKFABRIC_<hostname>_PROTECT".

Environment

Release : 6.x

Component : Symantec DLP Integration Pack

Cause

Per Oracle's Database Error Messages documentation, this error may indicate any of the following:

"The connection request cannot be completed within the allotted time interval. This may be a result of network or system delays, a firewall not allowing the connection, no network connectivity between client and server, or it may indicate a denial of service attack on the database server."

"The server shut down because connection establishment or communication with a client failed to complete within the allotted time interval. This may be a result of network or system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the server."

If you encounter this error while attempting to integrate DLP for the first time, the most common cause is the IP address or hostname entered in the Oracle Host Name field on the Database Settings page in the New Connection Wizard is incorrect.

Resolution

If you encounter this error while attempting to integrate DLP for the first time, correct the IP address or hostname in the Oracle Host Name field on the Database Settings page in the New Connection Wizard. If that does not resolve the error or you have encountered this error during processing, contact your Oracle database administrator or DLP administrator for assistance.