AeXNSAgent.exe Process High Commit (KB) and Hard Faults/sec
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AeXNSAgent.exe Process High Commit (KB) and Hard Faults/sec

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Article ID: 262196

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Updated On:

Products

IT Management Suite Inventory Solution

Issue/Introduction

It has been observed that a server may become unresponsive due to very high commits and hard faults.  When this situation happens, the only resolution is to reboot the server.  This was observed every 15-20 days.

Environment

Release: 8.6

Cause

Application Metering agent is installed on server

Resolution

In this particular situation, the Application Metering agent was installed on the server.  Reviewing the default target for the Application Metering agent install policy, Computers without Application Metering Plug-in, you will notice it includes members of the filter Computers with the latest SMP agent and without Application Metering Plug-in.  If you review the filter you will notice the SQL uses the following logic to filter out server operating systems:

CROSS APPLY dbo.fnSysMask_GetAllSystemMaskAsTable(ac.[OS System Mask]) sm
    ON ac._ResourceGuid = vc.Guid
    AND sm.[Type] = 2

Therefore, it can be concluded that you should not be installing the Application Metering agent on servers.  While it may work, it's not recommended and should be removed.  You may wish to look into using the Inventory Pack for Servers Plug-in.